scrollup
Pisilinux logo

GIMP

Emre Yılmaz / Uygulamalar / 22-10-2020 / 224

GIMP

GIMP

 

Şirket/geliştirici:

GIMP geliştiricileri

İşletim sistemi:

Linux, MS Windows, Mac OS X

Tür:

Resim Düzenleme

Lisans:

GPL

Web sitesi:

https://www.gimp.org

 

GIMP bir başka deyişle GNU Image Manipulation Program, gelişmiş bir resim oluşturma ve fotoğraf düzenleme yazılımıdır. GIMP, Adobe Photoshop ve benzeri kapalı kaynak resim işleme araçlarına eşdeğer bir işlevler bütünü sunar.

Yetenek ve özellikleri

  • Katmanlar, kanallar ve yollarla çalışabilme.
  • Çeşitli efekt araçları.
  • Eklentilerle sonradan yeni özellikler ekleyebilme.
  • Yüzlerce dosya biçimi desteği (XCFSVGTIFFPDFJPEGPNGGIF PostScript belgeleri (PS, EPS ya da sıkıştırılmış .ps.gz), BMP, Paintshop Pro dosyaları (PSP ya da TUB), Adobe Photoshop dosyaları (PSD).
  • Dosya türleri arasında dönüşüm yapabilme.
  • Gelişmiş seçim ve çizim araçları.
  • Hazır logo, desen (pattern), site tuşları, reklam alanları oluşturabilme.
  • Gelişmiş kesme, döndürme, fırça araçları.
  • Grafik tablet desteği.
  • EXIF bilgilerini düzenleyebilme.

İpuçları

  • Kovadan Dolum aracı CTRL tuşu ile birlikte kullanılarak ön plan rengi yerine arka plan rengi ile işlem yapılabilir.
  • Döndür aracı CTRL tuşu ile birlikte kullanılarak 15 derecelik açılarla döndürme sağlanır.
  • Katmanlar iletişim kutusundaki göz simgesine Shift tuşu ile birlikte basılarak o katman hariç tüm katmanlar gizlenebilir. İşlem tekrarlanarak tüm katmanlar görünür yapılabilir.
  • Yapıştırılan Katman üzerinde işlem yapmadan önce sağ tıklanarak Yeni Katman seçeneğiyle yeni bir katmana dönüştürülmeli veya Katmanı Çıpala seçeneğiyle kendinden bir önceki katmana çıpalanmalıdır.
  • Birçok eklenti yalnızca aktif olan katmanda çalışır. Eğer eklentinin tüm resim üzerinde çalışması isteniyorsa tüm katmanlar birleştirilmelidir (Resim> Resmi Düzleştir).
  • Bazı efektler tüm resimlere uygulanamaz. Bunlar menüde gri ve sönük olarak gösterilmiştir. Resmin kipi değiştirilerek (Resim> Kip), katmana bir alfa kanal eklenerek (Katman> Şeffaflık> Alfa Kanalı Ekle) veya resim düzleştirilerek (Resim> Resmi Düzleştir) aktif olmayan efektler kullanılabilir.
  • Seçim aracı kullanılırken Shift tuşu kullanılırsa yeni seçim önceki seçimlere eklenir. Eğer Ctrl tuşu kullanılırsa yeni seçim öncekilerden çıkarılır.
  • Çizim araçları (Boya Fırçası, Sprey veya Kalem) kullanılırken Shift tuşuna basılırsa son çizim noktasından fare imlecinin o anki konuma kadar düz bir çizgi oluşturulur.
  • Üzerinde daha sonra tekrar çalışılacak bir resmi GIMP'in yerel dosya formatı olan XCF (.xcf) biçiminde saklayın. Böylece katmanlar ve bitmemiş tüm işler korunur. Proje bitirildikten sonra JPEG, PNG, GIF gibi biçimlerin birinde saklanabilir.
  • Yollar aracı kullanılarak karmaşık seçimler yapılabilir ve var olan yollar düzenlenebilir. Yollar iletişim kutusu birden fazla yolla çalışılmasına ve yolların seçime dönüştürülmesine imkan sağlamaktadır.
  • Basit kare veya çember çizimleri Düzenle> Seçimi Darbele ile yapılabilir. Bu oluşturulan seçim alanının kenarlarını darbeleyecektir. Daha karmaşık şekillerin çizimi içinse Yollar aracı veya Filtreler> Tarama> Gfig kullanılabilir.
  • Boya araçları seçimi değiştirmek için kullanabilir. Bunun için resim penceresinin sol alt tarafındaki Hızlı Maskeleme butonu veya Shift+Q tuşları kullanılabilir. Resimde boyama yapılarak seçim değiştirilebilir ve Hızlı Maskeleme butonuna tekrar basılarak normal seçim moduna dönülebilir.

Kullanım önerileri

  • Eski bir Çin atasözü der ki: "GIMP'te Photoshop'u aramak yerine alışmaya bakın."
  • GIMP geniş ve üretken bir kullanıcı topluluğuna sahiptir. GIMP'i öğrenirken kafanıza takılan her türlü soruya kolayca cevap bulabilirsiniz.
  • GIMP ile diğer resim işleme programlarının yerel dosya biçimlerini (PSD vb.) açmak dışında, bu programlar için hazırlanmış fırça, betik ve eklentileri de kullanabilirsiniz.
  • Daha önceden bir resim işleme programı kullandıysanız GIMP ile uyum içinde çalışmaya başlanmanız uzun sürmeyecektir. Bazı araçların isimlerinin değişmesine, bazı efektleri gerçekleştirmek için farklı yollar izlenmesine ve bunun gibi küçük farklara ise zamanla alışacaksınızdır.
  • Hassas çizimler gerçekleştirmeniz gerekiyorsa bir lazer fare ya da daha iyisi bir grafik tablet almanız işlerinizi daha hızlı ve kolay yapmanızı sağlayacaktır.
  • Çizmek için hassas değil de eğlenceli bir yöntem arıyorsanız bu iş için ağ kameranızı kullanabilirsiniz.
  • GIMP eklentileriyle zenginleştirilebilen açık kaynak bir yazılımdır. İhtiyacınızı karşılayan eklentileri edinip hayalinizdeki resim işleme programına sahip olabilirsiniz. GIMP'in içeriğe duyarlı ölçekleme, siyah beyaz fotoğrafları otomatik renklendirme, CMYK desteği, katman efektleri, İnternet için kaydetme, droste efekti gibi onlarca faydalı eklentisi bulunmaktadır.
  • Fare tekerleğini fırça boyutunu değiştirmek veya resme yaklaşma / uzaklaşma yapmak gibi sık gerçekleştirdiğiniz işler için kullanarak hız kazanabilirsiniz. Örneğin resme yaklaşma / uzaklaşma eklentisini fare tekerleği ile çalıştırmak için: Düzenle > Tercihler > Giriş Aygıtları > Girdi Denetleyicileri bölümünden Main Mouse Wheel (temel fare tekerleği) seçeneğini seçebilir. Açılan iletişim penceresinden Scroll Up (yukarı kaydırma) hareketini iki kere tıklayarak iletişim penceresinden Görünüm > Yakınlaş değerini seçebilir. Scroll Down (aşağı kaydırma) içinse Görünüm > Uzaklaş değerini seçebilirsiniz.

Temel kısayol tuşları

GIMP aynı işlevi gören kapalı kaynak kodlu uygulamalarla benzer kısayol tuşlarına sahiptir;

Araç

Kısayol

Araçkutusu

 

Fırça

P

Silgi

Shift+E

Renkleri değiştir

X

Öntanımlı renkler

D

Dosya

 

Yeni resim

Ctrl+N

Resim aç

Ctrl+O

Resmi yeni bir katman olarak aç

Ctrl+Alt+O

Kaydet

Ctrl+S

Farklı bir isimle kaydet

Shift+Ctrl+S

Çıkış

Ctrl+Q

Görünüm

 

Tam ekran

F11

Hızlı maskeleme

Shift+Q

Yaklaş (Büyült)

+

Uzaklaş (Küçült)

-

1:1 Görüntü

1

Ekrandan tasarruf

Ctrl+E

Resmi pencereye uydur

Shift+Ctrl+E

Cetveli göster(me)

Shift+Ctrl+R

Kılavuzları göster(me)

Shift+Ctrl+T

Düzenleme

 

Geri al

Ctrl+Z

Yinele

Ctrl+Y

Kopyala

Ctrl+C

Kes

Ctrl+X

Yapıştır

Ctrl+V

Katmanlar

 

Tüm katmanları birleştir

Ctrl+M

Seçim

 

Hepsini seç

Ctrl+A

Seçimleri iptal et

Shift+Ctrl+A

Seçimi tersle

Ctrl+I

Eklentiler

 

Son eklentiyi tekrarla

Ctrl+F

Son eklentiyi göster

Shift+Ctrl+F